Solo not showing up

Hi I transferred solo from Binance into my trust wallet but when I add solo it says I have 0 coins.
Can someone please help

Much appreciated

1 Like

@Kermdaddy To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

1 Like

Just updated app still not showing up.

Version 7.0 now

Thanks very much for the help

Could I get you to check for my transactions too please?

Some funds arent showing up in my wallet either


You sent that to your Trust wallet on the smartchain network (BEP20) and not ERC20.
You only need to add it manually as a custom token using these details
Network: Smartchain
Contract: 0xc2c28b58db223DA89b567A0A98197Fc17C115148
Decimals: 15

Ah thank you so much it works now!

Appreciate the help so much

Have a good day