Unable to transfer USDT off my wallet - Help needed


I tried the wallet today for the first time and new to crypto, I have 129 USDT on my wallet now that I am unable to transfer off.

If I try and transfer $129 USDT off the wallet it asks for a network fee of 25$ in ETH that I don’t have, even if I reduce the gas fee to as low as possible I am still unable to transfer it off as I have no ETH.

If I try and convert some USDT to ETH I need to pay a network fee so I am unable to do that as I have no ETH

so if I want to move my money off the wallet I need to purchase a minimum of $50 of ETH just to transfer my money off the wallet?

if there is another way to do this or if i am doing this wrong please let me know.


I tried to send this in as a support request but on clicking submit there was no CAPTCHA, the browser just flashes and no support ticket was send through.

so if anyone can advise it would be greatly aprechiated.

So i have now tried to purchase $50 of ETH off the wallet, it charges at a much higher rate.

and then when i get through to make the payment it says Ammount off limits.

This app feels like a total scam, thats just how i feel right now…

When trying to submit a support case I get a error flashing up.

Provide your wallet address: cannot be left blank

There is no box to enter my wallet address

UPDATE Number 4

I have now purchased ETH on another app, transfered it over to try get my Crypto out of the APP

and every time it keeps failing but it wants an extortionate amount of network fees of 15$ to 25$ just to transfer off $129 !?!?!?!?!?!

1 Like

Hi @pauhegunor,

Please be informed that Trust Wallet is not the one who is charging those fees. The ETH gas fees goes directly to the miners. Learn more about gas fees here:

Regarding the expensive fees, there is an influx of transactions in the Ethereum blockchain, hence, the miners raised their requirements so they can confirm the transaction. More details here:

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. ETH address
  3. Transaction hash or link

Thanks for the reply, I understand it goes to the miners. Are these the SS you are after.
this one is still pending but this is the 3rd time i have tried as it has failed every other time.

1 Like

Please copy the transaction hash (the one in the screenshot) and send it here


Looks like you don’t have any failed transactions. How did you determine that it failed? https://etherscan.io/address/0xc583fac549f063443d5ba99e96a7bd7eeaa68e74

You have one pending tx now, which is this one: https://etherscan.io/tx/0x559d4b067d7c8f38ff79023fbebc68e36495de13104b125c5d71ca30e86ea100.

Since you used a low gas price, it will take time for the transaction to be confirmed. Learn more here:

I initiated the transaction 3 times, this is the 3rd time i have had to start the transaction as where is says Pending Transaction, it changed to Failed and text Changed to red and i had to process it again.

Thanks for your help, aprechiated but hopefully this one wont fail and it will be done in the morning, but its just annoying that it cost me 50$ to try get this transfered back out the wallet to the exchange and this one is still going.

1 Like

It is likely an internet connection issue, as there were no transactions that were broadcasted and returned failed.

As long as you didn’t change the gas limit, this tx won’t fail. It will just take a lot of time to be confirmed since the gwei right now is 90+ (https://www.gasnow.org/). And yes, I can relate to you. Currently, the gas fees are expensive and it’s indeed annoying. Hopefully, this lowers sooner or later.

still pending, 14hrs on a 10$ network fee, it only cost 9$ to transfer it to the wallet and it was done in under 5 minutes, The transaction is nolonger showing up on the app now it has taken that long but is still in the networking pending.

The DEV responce on the app store, they didnt even gove a damn about the problems i am having.

They just said its a network fee that goes to the miners, NO S*** Terrible support so far.

I sympathize with you, @pauhegunor. However, Trust Wallet is not the one in charge of confirming this transaction. Here is another explanation that could help you understand further:

Yeah but if you look at it from my perspective.

I did a transfer to trust wallet the process completes in less than 5 minutes at a 9$ fee
I do a 2nd transaction and its a 9$ fee and its less than 5 minutes.

I have tried 4 times now to take my money off this platform.

1 transaction has dropped at $10.24 because it went on for 1 day and 12 hrs
another transaction has been going now for 10 hrs when it said it should take 1 hr at $11.71, so yeah i think this one will drop also.

I think the platform has something to do with it.

Kinda suspicious how i can get instant transfers to trust wallet at $9 AT BUSY TIMES but its impossible to get my money off the platform at $11

and kinds suspicious how Trust wallet also Auto sets the Gass Price to $25 to $30 every time for a $130 transfer and if you lower it, it wont go through.

Checking the Gas Price as we speak.

Help explain this to me checking gasnow it says 100 Gwei is about $4 how does it say $14.54 on Trust wallet when i set it to 100 Gwei!?

200 is about $8 max on gasnow but when i set it on Trustwallet its $29!?

1 Like

Sorry, but you need to understand that transferring ETH is a simple transfer and the cost is lower than a token (like USDT) transfer that requires a smartcontract call (for the token contract).

You can try for yourself (don’t need to really send - just look at the fees before confirming).

Right now:

  • transfer ETH: $7.80
  • transfer USDT: $20.03

Does this explain to you why transfer IN ETH and transfer OUT USDT are so different in terms of gas?

I’m not talking about sending out ETH I’m talking about sending out USDT

So why was Trust Wallet charging 20$ to 30$ to send out $129 USDT When it only cost 9$ USDT to send 129 USDT to the wallet and it was on more or less the same time on the network

Every time I try to send it out from Trust Wallet it is extremely high, even when I check gasnow and its average is about 100/120 gwei, you set the gas charge on your app to about 20$ to 30$ but gasnow states 4$ to5$

Only when sending out from trust wallet the gas charge is extremely high even when the gasnow price is showing low?

Using Trust wallet it shows High $$$ cost but using other apps it shows low $$$ cost!?

Please be informed that Trust Wallet is not the one that is charging these network fees. It goes directly to the miners. And no, it didn’t cost 9 USDT for network fees, to receive 129 USDT. It was worth $21.15.

You used a centralized exchange where the withdrawal fees are fixed. Trust Wallet is not a centralized exchange, so you have to abide by the network fees.

You have to learn more about how ETH gas works. Sure, gasnow shows a different $, however, you have to take into consideration the gas limit. The usual gas limit for transferring USDT to another address is 84,313. Calculate (https://ethgasstation.info/calculatorTxV.php) it with the current gwei and you’ll get the maximum $ that you will spend.

I am trying to understand but something looks shady to me…

I set my Gwei price to 120
Gas limit 84313
Actual Gas used 41209

Due to slight fluctuation, thats roughly what it showed in your app yesterday, Image below shows max gas and the Gwei price.

I was happy to pay the 17$ in the end just to get my money out of the app with all the hastle, but why was $25 taken out of my ETH wallet. after i set the price to 17$ max

Below SS is of the actual transaction. gas used only 48% of the gass was used that shows $8.65 but the full 17$ was taken + close to an extra 10$, I had about 32$ of eth and after the transaction i had 6$ left

What happened to atleast the other 10$ as my price was set to 120 around $17$