Watch only wallet

I have downloaded my trust wallet and withdrawn someTWT too it from Binance.
I now find that I can’t make any transactions as it is a watch-only wallet. How do I alter the status of my wallet to one that lets me do transactions please ?


1 Like

Import your wallet … That way you wil be able to trade with it

Follow this for procedure

How to Import a Wallet


Hello Mateo,
Thanks for your reply.
I’ve had a look at the link you sent and it does not seem to help. When I open my Trust wallet I can see that there are 497.57 TWT in my Smart Chain Wallet but I am unable to do anything with them as my wallet is a ‘watch only’ wallet evidently. I don’t know how it became a ‘watch only’ wallet as I didn’t knowingly down load it as one, I thought that I would get just an ordinary Trust Wallet when I down loaded it from the App Store. Either way I’m now unable to do anything with these tokens.

1 Like

Hi @Abbeytrader,

You have to use your recovery phrase in order to import your wallet. Else, it will stay as a “Watch only” wallet.


Hello Friends!

I have the same problem, I have a wallet for a very long time, I tried today to send som ETH to another address, but it is a “watch-only” wallet.
After looking at some tutorials, I used my recovery phrase, but when I do that it creates another wallet, with nothing in it. And the initial wallet with the ETH in it it’s still watch only.
Any sugestions?


1 Like

Hello Andrei,
That is exactly what has happened to me. I used my recovery phrase and I have a new wallet with nothing in it but it looks like I will be able to do transactions.
I still have the original wallet with my tokens in but can’t do anything with it as it swatch only. I have sent an email to [email protected] but so far have not any reply. This is all very frustrating !

1 Like

Hey John,
If you manage to find out something, please share.
All the best!

Hi @Abbeytrader, there is no need to send an email since this website is one of the official ways to get support.

That being said, here are some few questions in order to clarify and troubleshoot the issue:

  • After importing the recovery phrase, have you checked the receiving address of your Ethereum? Is it the same?
  • Have you tried re-installing the app and importing using the recovery phrase?

cc: @AndreiAAV

Hello @iamdeadlyz, thank you for the reply.

I have checked, and unfortunately the addresses are not the same.
I cannot understand why, because I have only created only 1 wallet, at the moment when I transfered the ETH to Trust.

I will leave a printscreen here, because I have nothing to lose and the addresses are not entirely shown.
The first wallet is what I recovered with the key phrase, but the ETH are in the second, which is "watch only.
What I dont’ understand is why the first one is shown as a wallet, and the second one (where te ETH are) as an address.
Do I have any other options?

PS: The same thing happened when I re-installed the app.
I recovered the first wallet with the key phrase, and the second (where the ETH is), with the receiving address (whick I also have in the transaction history from the platform I send the coins).

Cheers to all!

cc: @Abbeytrader

@AndreiAAV, please try to enter your recovery phrase on BIP39 - Mnemonic Code, select ETH in the list of coins, and scroll down to the derived addresses. Try to find your address with its corresponding private key. If it does not appear, then you have used a different recovery phrase. You need to find the correct one, else, you cannot transact with your wallet.

1 Like

hello my friend where can i get the recovery phrase because i also have same problem watch-only wallet

Hi @Amazighi1998,

You can get the recovery phrase/private key/Keystore JSON file from where you got the address (Trust Wallet, Metamask, MyEtherWallet, etc.).


Have you received a reply? Thank you

Have anyone solved the problem ?

Hi @enhlham1,

Please do the following:

  • Make sure you have the backup of your recovery phrase, private key, or keystore JSON
  • Uninstall the Trust Wallet app
  • Install the app again
  • Import using the backup (do not import an address, that will turn your wallet as a watch-only)

I have been experiencing the same issue with the watch only wallet. I followed this advice and imported using the BACKUP, however this simply just created a new wallet WITHOUT the funds from my watch only wallet. I have a significant amount of funds in the watch only wallet and it now appears that I am unable to make any transactions with them, despite following all of the advice in this thread. I confirm that I used the correct recovery phrase, corresponding to the watch only wallet and have still not been able to recover my funds from the watch only wallet.
Please get back to me as soon as possible.

1 Like

Hello @ryanm,

Please check the receiving address of the imported wallet and the watch-only wallet. Compare and see if they are the same.

10 posts were split to a new topic: Recovering VeChain

Both wallets have the same address. Im still unable to make transactions which is ridiculous, especially given that the ‘watch only’ wallet was default.

What are the missing cryptos? Please state it and include screenshots of the imported and watch-only wallets.