XRP from Binance to BSC in Trust Wallet

Today I’ve send XRP from Binance to BSC in Trust Wallet. I’ve made this mistake, because it had to be send tot XRP in Trust Wallet. The transfer from Binance is ok. But the the money is gone. It’s not in BSC or in XRP in my Trust Wallet. Do you know how to fix this?

Hello @Martijs Send your wallet address and transaction hash in plain text too (copy and paste here).

Hey I have to same issue. I transferred XRP from binance to trust wallet and used native XRP transfer method but amount hasn’t shown up in my wallet.
Address: r4xGTmzszEbjWZLxfHqyqjNUSMynYRA3dH
Tx: D38C04EC3A4F217065D59E76953594B7E735ADD698430C840A17D529858D76E4
I’ve also attached some images too.
Used XRP scan and it does say I have the XRP it’s just not showing. Tried deleting wallet and reimporting it no success. It is also not XRP binance peg already tried.I also have the latest version of trust wallet on ios

Hey @amhazdido
Kindly try using a VPN to access your wallet or follow the troubleshooting guide below