XYO Mess, Please help me!

I traded ETH for XYO back in 2018 directly from XYO in their initial sale. I haven’t looked in my Trust Wallet in 3 years. The Trust Wallet is on an old phone that my daughter uses now. I opened the Trust app and can locate my wallet and the address matches the address I used for the transaction in 2018. So, somehow, I can access my wallet still. I have no idea where my recovery phrase is and I do not see the XYO in the wallet. I cannot find my XYO, nor am I able to see wallet transactions through Trust Wallet. I went to Ethscan and it says my wallet is worth about $1. I don’t see more transactions than the initial ETH transfers to get the XYO.

I have spent a few hours trying to figure this out and would love some help. THANK YOU!

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

  1. Trust Wallet app version 6.6

  2. Wallet Address: No QR code. when I try and open an asset, the app shuts down. This is the address: 0x90b5cac1d11c2163530ed88bb6948f1a19cf922f

  3. Hash: Not sure but there are only a few transactions attached to my Wallet

  4. Haven’t looked at the Wallet for a couple years and grabbed my old phone to check it out. Do not see the XYO I purchased in 5/2018 in their initial sale. I do not have the recovery phrase but am logged into the Wallet and I referenced my email from XYO in 2018 and the Wallet addresses match. Trust app is glitching and I cannot remove and reload because I do not have the recovery phrase.

  5. Not allowing me to attach screenshots. Have tried png and jpeg. Will try in a separate reply.

Hi @adamh619
You should be able to attach screenshots now
Please send as much details as possible.
Also note that your funds are in your wallet still

Not sure if you deleted your reply. I am still logged into the wallet. App is glitching. Can’t find any transactions when I try and run a report from 2018. Transactions from me Wallet’s address are visible on the blockchain.

Just seeing your new reply. Is XY Oracle not the asset I should be tracking?

You can see my Unnamed Wallet carries the address but shows a $0 balance.

Can you try adding the XYO as a custom token using these details below:
Contract - 0x55296f69f40ea6d20e478533c15a6b08b654e758
Decimals - 18

Glitch: I press an asset in my wallet and the app shuts down. Also, I just tried to add the custom token per your response. It appeared to work but when I clicked save, the app shut down.

Tried to add a recorded screen video but can’t attach here. I feel like we are making progress! THANK YOU! But, how can I access them when the Wallet is glitching?

Is your IOS on the recent upgrade?
Also check your app version if it is the recent one

The phone is on auto upgrade on on IOS 14.6. There is an update to 14.8 available.

App version is 6.6. I can try to upgrade the phone but I’m scared. True, lol

I can access a QR code with a Privacy Key from the wallet. Not sure if that is helpful or what to do with it.

You can backup your private key and keep that somewhere safe while you try updating your IOS.

Does the Private Key give me access to my assets in the Wallet in a different Wallet if I can’t get these glitches to stop? Updating now.

Hi @adamh619
yes you can recover/access your funds using your private key.

Upgrade taking forever. Old phone. Can I download Trust Wallet on my current phone and move the assets to my new Wallet by scanning the private key on my old phone?

Yes you can do that also. It will work as long you have your recovery keys/private key.

Dear please help me I sent many times email about my problem and they reply me e same like you I bought 1550 coins grx and after few hours they reducing automatically I check after 2 hours it was 1472 after that continue reducing reducing reducing I don’t know where was my coin are going now I have only 11 coins what should I do where was my coins gone

Hi @Rockey
it is not Trust Wallet issue. It is about tokenomics of the token you are holding. It’s better to contact project team and learn about their tokenomics and how it works.

Here’s their website: https://gravitx.space/

GravitX (GRX) is an elastic supply token built on the Binance Smart Chain.
Elastic supply tokens have a changing circulating supply. The idea is that instead of price volatility, what changes is the token supply through events called rebases.

Simple explanation. Price goes up, less tokens. Price goes down, more tokens.

You have to do research on tokens you want to buy before investing.