Sent crypto but didnt showed up

I send 3 Times 3 different crypto and what i send never showed up where i sent. How can i get Back? I tried to recover but it didnt worked please help.


Hello @Luki86 To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

Send a trc20 cryto to another wallet, the token was sent Successfully but the receiver didn’t receive the token since 2days now…

Hello, the same has happened to me, any help would be much appreciated!

  1. Trust Wallet app version: 6.8
  2. Crypto wallet address: 0xa417a00a269D90b93f265ABEFD9d09DE9aBD0633
  3. Transaction hash or link: 0x785ca045fc18175394ffac216d4b50f12a63b991029a012f43e9b580fdb0e63c
  4. Further details about your issue: send WETH from my trust wallet to a metamask, the funds never appeared in metamask but were removed from trust.

I’m having similar issues too. I sent GMEE yesterday. Didn’t receive it till now even though transaction was successfull.

Transaction hash: 0x60ef992e51b9b431e67987884b0108a4edb020c2ae09632dca81c94b02373698

My Trust wallet is: 0xFbB79b9166B64661c1B8727DB3184C8BA337e95f

Yet the fund hasn’t shown on my account.

The currency is GMEE

I’m having the same issue.
I used pancake swap to swap Cake>to ETH
The contract looks like Cake>BNB>ETH
I’ve deleted and imported my wallet like the guides said so.

Hello @IsaacMacias
You sent ETH on the polygon network to your metamask and therefore you need to add it as a custom token on the Polygon network to view your funds.

Hello @Sarsanzo
Your Transaction hash shows no history of any sent or received tokens.
Kindly crosscheck that you have the right address.

Hello @Rosalesr930
You most likely have Binance pegged ETH and you only need to add it as a custom token.
See guide below:


That’s the explorer of GMEE. And the transaction is showing successful. I sent it to a Trust wallet GMEE address


A post was split to a new topic: Sent 3 links to bundle

@Sarsanzo try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Token details:-
Network: polygon
Contract: 0xf8a0bf9cf54bb92f17374d9e9a321e6a111a51bd
Decimals: 18

I. Have. I have the wallet address already. But isn’t showing my balance even after transferring the coin from a different wallet address to it. My balance is not showing on Trust wallet. But the explorer is showing that the transaction was successfull

@Sarsanzo have you follow the instructions I sent above? If no, try to add as custom token. If you added, click on token you added and screenshot.

I have. The wallet address remains the same with the one i sent the coin into. But the balance didn’t reflect

How do i send screenshot here… It’s showing can’t embed image with text

@Sarsanzo you can send screenshots now. I have enabled media sharing for you.

Ok thanks. I’ve received my token.