Transferred but not showing, please help

Hi there, good evening !

I have a -problem and need some help.

I have transferred some Binance-Peg Ethereum Tokens to my Mew wallet which i thought was normal eth, so i sent it back to my trust wallet and it is not showing anywhere. it is completed.

here is the transaction hash :


Kinda weird because i never had that issue before, please help and resolve.



Hello @steveovich
Please note that your token is in your wallet as Binance-pegged ETH (BEP20 ETH) and you only need to add it as a custom token
See guide below:

Hi there. This is not the issue here. I allready had the binance peg eth token in my trust wallet. So the custom token is there. But it stays on zero?


@steveovich try to use VPN and refresh your wallet, if problem persists try to reimport your wallet, here’s guide: How to Re-Import your Wallet

Hi there, thanks for the reply, did that just now, no succes. Still not showing the peg eth.
Any other suggestions?

Hello @steveovich
If this is truly the receiving address 0x4528d43e1b60cb9573b90157dcc1ea6b5573c805 you have on your Trust app then your funds are in your wallet, you can also check on the Bscscan.
The problem may be from your network provider or device.
Did you also try importing your wallet to another device?

hi jenny, i imported the wallet, reinstalled it, dont got anoither device but it is still not there, weird thing is that it was in my wallet before i send it to mew online wallet. after sending it back the same way it isnt showing up anymore, bscscan is correct. it was send and completed. i really need some help with this.


i have your problem too
i bougth Data coin and i dont receive it in my wallet
what should i do?


I also am experiencing a very similar problem. I transferred MATIC tokens from coin base and none of my tokens ever arrived.

I’m having similar issue.
I tried sending funds to uniswap today but saitima. But no funds showed up on uniswap but it’s all disappeared on my trust wallet ??

Hello @atenavsh , @steveN6 , @thirathluong
To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

@atenavsh, Please try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Token details:-
Network: Ethereum
Contract: 0x8f693ca8d21b157107184d29d398a8d082b38b76
Decimals: 18

@steveovich, Please try to add it as custom token again. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Use these details:-
Network: Smart Chain
Contract: 0x2170ed0880ac9a755fd29b2688956bd959f933f8
Decimals: 18

Did that just now, still not showing up. dont know what is wrong here but this sucks !

@steveovich can you click on token you added and screenshot (balance and blockchain/network should be visible on top left corner.)

it is blocked for capturing screenshots. But it says bep20
0 eth. I did exactly how you told me to do it, it isnt showing up

4 posts were split to a new topic: Transferred some amount of xrp