Unable to see Tokens in Trust Wallet

I purchased My Shiba Academia (MSA) on PancakeSwap and am unable to see the tokens in my Trust Wallet. Attached are a screenshot of the Wallet QR code, Wallet balance, and Wallet version. I have deleted and re-imported the wallet but I am still not able to see the funds. Please let me know how I should resolve this issue.

Crypto Address: 0xa194fab45d372578d4a4406b5a4b4e875aa6aa18
Transaction ID : 0x9ad4bb4c8c4d2f14b69a606fbc8bcb9de22eedbbc34c8fc49d4fae27227ae373

Hi, Please try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Token details:-
Network: Smart Chain
Contract: 0x93a20a5f1709659005e1610D1a022d5f1e2D0DF7

1 Like

It’s been 3 days since I sent the screenshots of my screens of my QR code about my wallet which has a zero balance despite the correct entry of my 12 words. So far I have no returns and I want to get my coins back as it has been an investment for months. This is for your credibility please.


Hey Alan. Can you help me figure out where my $10,000 went: I traded Safemoon for BNB and I kept getting the message “unable to make transaction “ regarding gas fees etc. I changed the slippage to 12%
All my Safemoon are gone and I have NO BNB … I used the genuine pancake swap site and on Safemoon wallet tracker I can see they were sold.
I’d appreciate your help

1 Like

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

Hi thanks for helping. I’ve tried everything I know and nothing has worked


@Silverset send your wallet address and transaction hash in plain text (copy and paste).

1 Like

Hi here’s this transaction#


you swapped your SafeMoon tokens for Binance peg BTC not BNB.

Try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Token details:-
Network: Smart Chain
Contract: 0x7130d2a12b9bcbfae4f2634d864a1ee1ce3ead9c
Decimals: 18

1 Like

I need to retrieve my wallet

Yesterday afternoon it suddenly restarted (it had never happened), I typed in the password and then I asked for 12 words, I typed it correctly, to open wallet, it’s not mine, it’s a totally zeroed wallet with no coin and numbering different from my previous one. A new wallet that I never saw because I only had one wallet. What to do? I need to solve it URGENTLY

If you have reimported a wallet with zero balance, then you used another recovery phrase

no, I’ve never made another wallet just this one
I kept the address and words together
this is a trust bug that needs to be resolved urgently.

I have added as custom token, now it shows MSA tokens but it doesnt show in $ value like others coins

I did not send any money out of my account on 02.11.2021, but I am not the one who made the attached transactions, none of the out transactions belong to me.

I also need help. I transferred Binance-Peg Ethereum to Ethereum in TRUST and I think i just burned my coins… Is this true?

Pretty sure im screwed.

Just add your Binance pegged tokens manually as a custom token
See guide below:

Good afternoon Alan:

Please assist me. I tried to contact trust support but I have not heard back. I am unable to see the two tokens I purchased from Ertha NFT.

The is a my bsc address in my trust walllet: 0xdb5a26dc4f2ca367719e34f15012b0a030c9b29d

The two transactions ids are:



Thank you for your assistance.

So I tried this an no love showing up

Is it possible because it’s binance peg Etherium to etherium that it burned?

A post was split to a new topic: Bought metamars token