Replacement Transaction Underpriced

I’m getting this error and it’s super frustrating. (ETH Wallet)
I removed my trust wallet and input the secret phrase.
Still same error
I changed the ETH Node to 2 (manually) (after reinstalling the wallet)
Still same error
I increased the minimum miner tip to 2 and the transaction gets stuck.
What do I do?
I see many people on twitter have the same problem.
We need a final solution to this!

Hello @exjack
Please update your Trust app to the recent version and try again.

I’m removing it and reinstalling the latest version.
Any other solutions?

@exjack Try that and let us know if it works or not.

Didn’t work any other suggestions???
What is the miner tip suppose to be?

It didn’t work i’m on the latest version 9.6 (802)
I tried installing on 2 different devices, Apple ios and Google os.
Nothing is working… what is the next move?
Question could vpn be an issue?

@exjack Okay please follow this below:

  • Reimport your wallet
  • Generate a transaction with a custom nonce based on your last successful transaction, and add 1 to it.
1 Like

It worked thank you so much
This is the full solution then. +1 on the old transaction
Please if you can put this somewhere in the support articles
It’s very important for everyone to know


@exjack Glad to know that.
Stay SAFU.

Hola Tobi, genio, te molesto un minuto para ver si me podes ayudar a mi tambien, tambien me tira el mismo, error, pero doy +1 en nonce y no me tira, pero se me queda en estado pendiente y no se termina de enviar, queda congelado ahi.

Puede explicarlo por aca, asi le queda a la comunidad para que otro lo pueda arreglar

Hello @POMENUK it’s a scammer please try talk to us in english , and don’t call him on telegram don’t share your 12 Words .

Hello kamon, thank you for the advice. Yes, I’ve noticed it right away. The issue I’m facing is that from my wallet, it doesn’t let me send. First, I got the error “Replacement Transaction Underpriced”. I followed tobi’s advice and added +1 to the nonce it was giving me, and the transaction went through. However, it’s still pending, like it got stuck, and I’m not getting a hash on bsscan.

Can you try the last version of Trust Wallet ? in the AppStore or Google Play , What is your version of Trust Wallet ?

or Try it

It’s happening to me on both the extension and the Android application, and I’ve already reimported four times and it’s still not working.
Android version: 8.1.1
Browser extension version: 2.0.0

“Error: transaction underpriced” usually happens when the “gasPrice” you are willing to pay is very low and not accepted by the network . In your code, you are not setting the “gasPrice” so it will probably 0 or a very low default value.

I don’t know how much money you are trying to send but you can send less and let some money for the fees .

See this too :

Yes, I also did that and set the gas a bit higher at 0.11 USD worth of BNB, but it’s still pending.

You should wait and comeback later if it’s still bad . …

Hi. I keep getting the same error when I try to cancel a malicious smart contract call pending transaction using the trust wallet community guide. If I were to up the amount, any amount less than 95% of my existing ETH in my wallet would trigger the same message, while any amount more would get error message “transaction overdraft” or “insufficient gas fee”.

As a result, all my ETH and ERC-20 token related transactions are stuck. How do I resolve this?

Warm Regards,

@elew I’m not sure i understand what you’re saying, can you upload screenshots of this.