Tokens sent successfully, but still show 0 balance


I have added the TKING token to my wallet, I sent some TKING tokens from another wallet to my Trust Wallet address, the transaction was marked success.

The problem is, the TKING tokens have disappeared from my sending wallet and I still have a zero balance for TKING tokens in my receiving Trust Wallet.

Please help me!

receive wallet address: 0x2fFcbDa4456E51A8fCf1671f817Fcc89c2979453
transaction: 0x02a830d897d233da6208f425653e000c19a465b0c0c00a16b3f89d978ebb3f63
using TW on iOS v 8.6 (861)

1 Like

Hello @ajacks504 try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Contract: 0xc626d951eff8e421448074bd2ad7805c6d585793
Decimal: 18

1 Like

Hi Alan,

Thanks for your prompt response, now I’ve got a grip on what happened.

I had TKING contract [0xc626d951eff8e421448074bd2ad7805c6d585793] - when I added this custom coin, it showed up.

I seems the real TKING contract is [0x24e89bdf2f65326b94e36978a7edeac63623dafa] - I have a zero balance of this.

What happened? I bought hot garbage using the wrong contract address?

1 Like

Hi guys, I had same issues two days ago, and still haven’t figured it out yet. I sent out my yooshi bpe20 to Bnb and the fund is still not showing? Help please


please send your transaction ID and I’ll take a look. It seems most likely that you made a similar error to me, used a wrong contract adress.

1 Like

@ajacks504 you have to check with the project team to confirm if it is correct contract address.

I have same problem.
I sent xrp to my trust wallet from
Transaction appears completed.
But balance showing 0



Pls help

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

Hi there
I recieved Shiba Inu BEP20 coins but still there balance value in usd is not showing in my wallet

Attached are documents


@Tag77 we are aware of this issue. Team is working on fix. Nothing to worry about as long as the balance is correct.

1 Like



Hello @Doncons try to use VPN and refresh your wallet. Try different servers/vpn apps.

If problem persists try to re-import your wallet: How to Re-Import your Wallet

1 Like

Good day sir. I tried both your recommendation… still my xrp showing 0 balance… :sob:

Good day sir. I tried both your recommendation… still my xrp showing 0 balance… :sob:

Hi, i have same issue on Ethereum, from Ethermine.

I have waited for 5 hours, but the trust wallet still showing 0 ETH. May i know what is happening?

Transaction hash: 0x6fe4793952afb4d24649a3b4d97e7a678f71731b29335cf15d378c48fd6679fb
Received wallet address: 0x8Cc6aa8a5889aD489da7271B152b63E55EFA0106

Please help me, i don’t know what happen…

Your transaction hash shows no history of any Ethereum sent or received.
Please ensure you have the right one.

My wallet address is 0x8Cc6aa8a5889aD489da7271B152b63E55EFA0106.

I used TrustWallet, set Wallet Address from MyEtherWallet, and connect to Ethermine by using Wallet Connect.

If in that case, what should i do now? First time want to withdraw the Ethermine :frowning:

A post was split to a new topic: BNB not showing up

I transferred MATIC currency to TRUST WALLET from KOCOIN exchange on KCC network, but I still do not see it in my wallet please help me

Trust wallet currently doesn’t supports KCC blockchain

You have to extract your MATIC private keys using this guide: How To Recover Funds Sent to a Wrong Public Address

Select ETH in the coin part. Scroll down to the list of derived addresses and get the private key in the first row.

After getting the private key, Import to wallet that supports KCC blockchain eg. Metamask.

[in case you use Metamask] Set the custom blockchain as shown on this guide: How to Add Kucoin Community Chain (KCC) Network to Metamask

1 Like